OSPF Virtual link

How to configure Mikrotik OSPF Virtual link

OSPF Virtual link configuration on mikrotik. this is golden rules of OSPF that all area must be connected with backbone area 0. R1 Router Configure [atik@R1] > ip address add address=1.1.1.1/32 interface=loopback0 [atik@R1] > ip address add address=172.16.15.1/30 interface=ether1 [atik@R1] > ip address add address=172.16.10.1/24 interface=ether2 [atik@R1] > routing ospf instance set router-id=1.1.1.1 name=default disabled=no numbers=0 [atik@R1] > routing ospf area set backbone disabled=no area-id=0.0.0.0 [atik@R1] > routing ospf network add network=172.16.15.0/30 area=backbone [atik@R1] >… Read More

Continue Reading

How to Block Website on Mikrotik

Mikrotik Firewall is a powerful tolls for block website. there is many way to block website in Mikrotik.This has the advantage of also blocking other traffic such as ftp or torrent downloads as well. if you are network engineer you want to block website or specific service then you need to create filter rule and drop this website or service. now we share how to block website on Mikrotik Router. ip firewall layer7-protocol add name=Facebook… Read More

Continue Reading

How to Configure PPTP Server on Mikrotik

Point to point tunneling protocol (PPTP) is a network protocol to provide virtual private network,PPTP VPN  not define encryption features and relies on the Point-to-Point Protocol being tunneled to implement security functionality. PPTP is the most popular for windows user because of PPTP is useful for slower device,easy to setup and computationally fastest VPN protocols.   now we are configure PPTP server on Mikrotik. Create pool for PPTP user. /ip pool add name=VPN-PPTP ranges=172.16.10.10-172.16.10.20 then create PPTP profile for remote… Read More

Continue Reading

Mikrotik Router L2TP Configure

L2TP means Layer 2 tunneling protocol. L2TP is a tunneling protocol used to support Virtual private network(VPN). L2TP VPN The World’s Highly Secured VPN Protocol. L2TP does not provide any encryption. it depend on encryption protocol  that it passes within the tunnel to provide privacy. Now we configure L2TP VPN on Mikrotik. IP pool create fro VPN client /ip pool add name=”vpn” ranges=172.16.10.2-172.16.10.14 then need to create VPN profile /ppp profile add name=l2tp-vpn local-address=172.16.10.1 remote-address=vpn use-encryption=required change-tcp-mss=yes… Read More

Continue Reading

How to block torrent in mikrotik

if anyone want block torrent in their local network for avoid unwanted bandwidth utilization. please follow below configuration. /ip firewall layer7-protocol add comment=”Block Bit Torrent” name=Block-Torrent regexp=”^(\\x13bitt\ orrent protocol|azver\\x01\$|get /scrape\\\?info_hash=get /announce\\\?inf\ o_hash=|get /client/bitcomet/|GET /data\\\?fid=)|d1:ad2:id20:|\\x08’7P\\)[\ RP]” /ip firewall filter add action=add-src-to-address-list address-list=Torrent-Conn \ address-list-timeout=2m chain=forward layer7-protocol=\ Block-Torrent src-address=192.168.1.0/24 src-address-list=\ !allow-bit add action=add-src-to-address-list address-list=Torrent-Conn \ address-list-timeout=2m chain=forward p2p=all-p2p src-address=\ 192.168.1.0/24 src-address-list=!allow-bit /ip firewall filter add action=drop chain=forward dst-port=!0-1024,8291,5900,5800,3389,14147,5222,59905 protocol=tcp \ src-address-list=Torrent-Conn add action=drop chain=forward dst-port=!0-1024,8291,5900,5800,3389,14147,5222,59905 protocol=udp \… Read More

Continue Reading

How to Configure PPPOE Server on Mikrotik

  Point to Point Protocol over Ethernet (PPPOE). PPPoE protocol was published by the IETF in 1999. PPPOE use standard method encryption, authentication, and compression specified by PPP. in this tutorial we share how to configure PPPOE Server on Mikrotik Task 1 IP Pool Configure Task 2 PPPOE Server Configure Task 3 PPPOE Profile Configure Task  4 PPPOE User Create Task 4 IP blocks for different bandwidth packages Task 1 Configure [admin@XYZ] /ip pool> add name=512KB ranges=192.168.1.2-192.168.1.254… Read More

Continue Reading

How to Configure Mikrotik hotspot default queue

  When you configure a hotspot with Mikrotik, routerOS always creates a default queue called hs-<hotspot1> allowing unlimited speed both directions. You can delete the queue, but it will come up again after restart. The problem is that this queue will override simple queue which are below it and speed limitation of hotspot users will not work properly. This can be easily avoided by the script : :foreach i in=[/queue simple find name=”hs-<server1>”] do {/queue… Read More

Continue Reading
Bonding

How to Configure Mikrotik Bonding With Cisco Switch

Bonding is a technique that allows aggregation of multiple Ethernet links into a single virtual link, that provides higher data rates and providing failover. For  Configure Minimum License require level1 and need minimum 2 NIC card. To add Bonding interface in R1 and R2 /interface bonding add name=bwbond slaves=ether1,ether2 / ip address add address=172.16.0.1/24 interface=bwbond bonding interface needs a couple of seconds to get connectivity with its peer On Cisco Switch in L3 Mode interface… Read More

Continue Reading

Skype Separate Bandwidth in Mikrotik

 If anyone want to separate Skype bandwidth in Mikrotik. please execute below configuration. /ip firewall layer7-protocol add name=skypenack regexp=”[\\\\|\\xd5]” /ip firewall mangle add action=add-src-to-address-list address-list=skype address-list-timeout=1h chain=forward disabled=no layer7-protocol=skypenack packet-size=39 protocol=udp  add action=mark-connection chain=forward connection-rate=0-50k disabled=no new-connection-mark=conn_skype passthrough=yes protocol=udp src-address-list=skype add action=mark-connection chain=forward connection-rate=0-50k disabled=no dst-address-list=skype new-connection-mark=conn_skype passthrough=yes protocol=udp add action=mark-packet chain=forward connection-mark=conn_skype disabled=no new-packet-mark=skype passthrough=no ####Below For Mange Skype Bandwidth in Mikrotik /queue simple add name=skype-bw max-limit=2M/2M packet-mark=skype priority=8 queue=default or /queue tree add… Read More

Continue Reading