How to Configure Mikrotik hotspot default queue

When you configure a hotspot with Mikrotik, routerOS always creates a default queue called hs-<hotspot1> allowing unlimited speed both directions. You can delete the queue, but it will come up again after restart. The problem is that this queue will override simple queue which are below it and speed limitation of hotspot users will not work properly. This can be easily avoided by the script : :foreach i in=[/queue simple find name=”hs-<server1>”] do {/queue simple remove $i;}; Setup scheduler to run the script every 5-10 minutes and you will be…

Read More

How to Configure BGP on Mikrotik

  Configuration IP Address in ISP Mikrotik for Peering IIG [admin@ISP] > ip address add address=172.16.1.2/30 interface=ether2 [admin@ISP] > ip address add address=172.16.2.2/30 interface=ether3 IIG 1 IP address Configure for Peering [admin@IIG1] > ip address add address=172.16.1.1/30 interface=ether2 IIG 2 IP address Configure for Peering [admin@IIG2] > ip address add address=172.16.2.1/30 interface=ether2   Configuration of global routing process BGP ISP AS Number:12345 [admin@ISP] > routing bgp instance add name=IIG1 router-id=172.16.1.2 as=12345 [admin@ISP] > routing bgp instance add name=IIG2 router-id=172.16.2.2 as=12345 BGP Peer Configure with IIG1 routing bgp peer add name=IIG1 instance=IIG1…

Read More

How to configure DHCP server in Mikrotik

Dynamic Host Configuration Protocol (DHCP) is a protocol that provide IP address and other related configuration information such as subnet mask and default gateway. Benefit of DHCP #Centralized IP configuration. #Ability to define IP address from central Location. #Ability to assign a full range of additional IP configuration values by means of DHCP options. in this tutorial we share how to configure DHCP server in Mikrotik. First we login Mikrotik via Winbox then go to IP>DHCP Server then click DHCP setting then select which interface you want use DHCP Service then…

Read More

Mikrotik Router Basic Command

Mikrotik command line almost same as Linux  command, mikrotik use this is a Linux kernel, the result of processing back from the Debian distribution of Linux. Use the same command shell, For example IP ADDRESS command in mikrotik.  just type in the IP ADD spaced press the TAB key, then the it will recognize and translate the IP ADDRESS command. Let us continue with the introduction of this command. Once logged in, check the condition of the interface or Ethernet card.   For View interface status. [aknet@Oriental-Navana] > interface print…

Read More

How to Configure detect mail spammer on Mikrotik

Here is the solution of detect or Block mail spammer /ip firewall filter add chain=forward protocol=tcp dst-port=25 src-address-list=spammer action=drop comment=”BLOCK SPAMMERS OR INFECTED USERS” add chain=forward protocol=tcp dst-port=25 connection-limit=30,32 limit=50,5 action=add-src-to-address-list address-list=spammer address-list-timeout=1d comment=”Detect spammers” Posted By: Techguru    

Read More

How to Configure Load balancing in Mikrotik

Load Balancing is  method to separate bandwidth to multiple Link. in this tutorial we use PCC(Per Connection Classifier) method for Load Balancing. /ip address add address=192.168.100.1/24 interface=LAN add address=172.16.31.2/30 interface=Uplink1 add address=172.16.30.2/30 interface=Uplink2 /ip dns set allow-remote-requests=no cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8,4.2.2.2 /ip firewall mangle add chain=input in-interface=Uplink1 action=mark-connection new-connection-mark=UP1_Conn add chain=input in-interface=Uplink2 action=mark-connection new-connection-mark=UP2_Conn add chain=output connection-mark=UP1_Conn action=mark-routing new-routing-mark=to_uplink1 add chain=output connection-mark=UP2_Conn action=mark-routing new-routing-mark=to_uplink2 add chain=prerouting dst-address=172.16.31.2/30 action=accept in-interface=LAN add chain=prerouting dst-address=172.16.30.2/30 action=accept in-interface=LAN add chain=prerouting connection-mark=UP1_Conn in-interface=Local action=mark-routing new-routing-mark=to_uplink1 add chain=prerouting connection-mark=UP2_Conn in-interface=Local action=mark-routing new-routing-mark=to_uplink2 /ip route add dst-address=0.0.0.0/0…

Read More

How to configure IPSEC between Mikrotik and Cisco

  IPSEC means internet protocol security. ipsec provide  security services for IP packets such as encrypting sensitive data, authentication, protection against replay and data confidentiality. in this topology we configure IPSEC between Mikrotik and Cisco. Mikrotik Configure Mikrotik Initial Configuration done. now we configure ipsec. for ipsec configure we need to allow below port and protocol. – Port 500/UDP – Port 4500/UDP – Proto 50 – Proto 51 [atik@xyz]  ip firewall filter add chain=input proto=ipsec-ah action=accept place-before=0 [atik@xyz]  ip firewall filter add chain=input proto=ipsec-esp action=accept place-before=0 [atik@xyz]  ip firewall filter add…

Read More

How To Configure Inter-Vlan Routing in Mikrotik Router

  Configure Inter-Vlan Routing in Mikrotik Router vlan divide broadcast domain. when need one vlan communicate to other vlan that time traffic must be routed between them. this called inter-vlan routing. Step 1 Create Vlan under interface in Mikrotik Router [atik@xyz] /interface vlan> add vlan-id=100 name=MKT interface=ether1 [atik@xyz] /interface vlan> add vlan-id=200 name=Sales interface=ether1 Assign IP in Desire Vlan [atik@xyz] /ip address> add address=192.168.10.1/30 interface=MKT [atik@xyz] /ip address> add address=192.168.20.1/30 interface=Sales Now we configure trunk port in Cisco Switch IOU1#conf t Enter configuration commands, one per line. End with CNTL/Z. IOU1(config)#int e1/0 IOU1(config-if)#no…

Read More

Address Resolution Protocol(ARP)

ARP Means Address Resolution Protocol. its used for Decision of internet Layer Address into data link layer. ARP basically used mapping a network address into Physical Address(MAC Address). ARP has been implemented with mixed network layer and data link layer. Type of ARP ARP The ARP Message (“who is X.X.X.X tell Y.Y.Y.Y”, where X.X.X.X and Y.Y.Y.Y are  IP Address’) is send using Ethernet Broadcast, and an Ethernet protocol type of value 0x806. Since it is broadcast, it is received by all systems in the same collision domain. This is ensures that is…

Read More

Skype Separate Bandwidth in Mikrotik

Bandwidth Management is an essential part every day. today i will show how to separate bandwidth for Skype in Mikrotik for uninterrupted Audio and Video Calling. /ip firewall layer7-protocol add name=skypenack regexp=”[\\\\|\\xd5]” /ip firewall mangle add action=add-src-to-address-list address-list=skype address-list-timeout=1h chain=forward disabled=no layer7-protocol=skypenack packet-size=39 protocol=udp add action=mark-connection chain=forward connection-rate=0-50k disabled=no new-connection-mark=conn_skype passthrough=yes protocol=udp src-address-list=skype add action=mark-connection chain=forward connection-rate=0-50k disabled=no dst-address-list=skype new-connection-mark=conn_skype passthrough=yes protocol=udp add action=mark-packet chain=forward connection-mark=conn_skype disabled=no new-packet-mark=skype passthrough=no ####Below For Mange Skype Bandwidth in Mikrotik /queue simple add name=skype-bw max-limit=2M/2M packet-mark=skype priority=8 queue=default or /queue tree add burst-limit=0 burst-threshold=0…

Read More