How to Configure Basic EIGRP

 

EIGRP(Enhanced Interior Gateway Routing Protocol) is an advanced distance-vector routing protocol that use on Computer Network. its Cisco proprietary. Partial functionality of EIGRP was converted to an open standard 2013. EIGRP supports classless routing and VLSM, route summarization, incremental updates, load balacing and many other features.Routers running EIGRP must become neighbors before exchanging routing information. EIGRP use Multicast address 224.0.0.10.

in this tutorial we configure basic EIGRP.

 

 

 

 

 

R1 initial Configure

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int e0/0
R1(config-if)#no sh
R1(config-if)#ip add
R1(config-if)#ip address 192.1
*Apr 10 11:18:54.387: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Apr 10 11:18:55.395: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#int e0/1
R1(config-if)#no sh
R1(config-if)#
*Apr 10 11:19:11.235: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Apr 10 11:19:12.235: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
R1(config-if)#ip add
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#

R2 initial Configure

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int e0/1
R2(config-if)#no sh
R2(config-if)#ip add
R2(config-if)#ip address 192.1
*Apr 10 11:20:17.603: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Apr 10 11:20:18.607: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#int e0/0
R2(config-if)#no sh
R2(config-if)#ip add
R2(config-if)#ip address 10.
*Apr 10 11:20:31.159: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Apr 10 11:20:32.163: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up1
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#

EIGRP Configure with R1 and R2

R1(config)#router eigrp 10
R1(config-router)#no au
R1(config-router)#no auto-summary
R1(config-router)#net
R1(config-router)#network 10.10.10.0
R1(config-router)#net
R1(config-router)#network 192.168.1.0

R2(config)#router eigrp 10
R2(config-router)#no au
R2(config-router)#no auto-summary
R2(config-router)#net
R2(config-router)#network 10.10.10.0
R2(config-router)#net
*Apr 10 11:22:28.579: %DUAL-5-NBRCHANGE: EIGRP-IPv4 10: Neighbor 10.10.10.1 (Ethernet0/0) is up: new adjacency
R2(config-router)#net
R2(config-router)#network 192.168.2.0

 

Verification

R1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(10)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
(sec)         (ms)       Cnt Num
0   10.10.10.2              Et0/1             14 00:00:48   22   200  0  6

R1#show ip route

 

 

 

Related posts

Leave a Comment