How to Configure BGP with Multihop

 

Configure BGP with Multihop

ISP Router Initial Configure

ISP#conf t
Enter configuration commands, one per line. End with CNTL/Z.
ISP(config)#int lo
ISP(config)#int lo0
ISP(config-if)#ip a
*Apr 7 19:46:36.047: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
ISP(config-if)#ip add
ISP(config-if)#ip address 1.1.1.1 255.255.255.255
ISP(config-if)#int e0/0
ISP(config-if)#no sh
ISP(config-if)#
*Apr 7 19:47:01.939: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Apr 7 19:47:02.939: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
ISP(config-if)#ip add
ISP(config-if)#ip address 10.10.10.1 255.255.255.252
ISP(config-if)#

CLIENT Router Initial Router Configure

CLIENT#conf t
Enter configuration commands, one per line. End with CNTL/Z.
CLIENT(config)#int loo
CLIENT(config)#int loopback 1
CLIENT(config-if)#
*Apr 7 19:49:08.039: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
CLIENT(config-if)#ip add
CLIENT(config-if)#ip address 2.2.2.2 255.255.255.255
CLIENT(config-if)#int e0/1
CLIENT(config-if)#no sh
CLIENT(config-if)#no shutdown
CLIENT(config-if)#ip add
CLIENT(config-if)#ip address 10.
*Apr 7 19:49:32.047: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Apr 7 19:49:33.047: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
CLIENT(config-if)#ip address 10.10.10.2 255.255.255.252
CLIENT(config-if)#int e0/0
CLIENT(config-if)#no sh
CLIENT(config-if)#ip
*Apr 7 19:49:48.987: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Apr 7 19:49:49.987: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
CLIENT(config-if)#ip add 192.168.1.1 255.255.255.0

CLIENT#ping 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms

Need Static Route For reachability

CLIENT(config)#ip route 2.2.2.2 255.255.255.255 10.10.10.2

ISP(config)#ip route 1.1.1.1 255.255.255.255 10.10.10.1

BGP Configure ISP End

router bgp 200
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 version 4
no auto-summary

BGP Configure Client End

router bgp 100
no synchronization
bgp log-neighbor-changes
network 192.168.1.0
neighbor 1.1.1.1 remote-as 200
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback1
neighbor 1.1.1.1 version 4
no auto-summary

Verification

CLIENT#show ip bgp neighbors 1.1.1.1

ISP#show ip bgp neighbors 2.2.2.2

 

Posted By:Techguru

 

 

 

Related posts

Leave a Comment