How to Configure Multiarea OSPF in Cisco

 

Configure Multiarea OSPF in CIsco

R1 Initial Contigure

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int e0/0
R1(config-if)#no sh
R1(config-if)#ip add
R1(config-if)#ip address
*Apr 4 10:30:32.875: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Apr 4 10:30:34.159: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#int e0/1
R1(config-if)#no sh
R1(config-if)#ip add
R1(config-if)#ip address 10.1
*Apr 4 10:30:53.515: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
R1(config-if)#ip address 10.10.10
*Apr 4 10:30:54.535: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#

R2 Initial Configure

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int e0/0
R2(config-if)#no sh
R2(config-if)#ip add
R2(config-if)#ip address
*Apr 4 10:32:35.719: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Apr 4 10:32:36.727: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
R2(config-if)#ip address 10.10.10.2 255.255.255.0
R2(config-if)#int e0/2
R2(config-if)#no sh
R2(config-if)#ip add
R2(config-if)#ip address
*Apr 4 10:32:56.775: %LINK-3-UPDOWN: Interface Ethernet0/2, changed state to up
*Apr 4 10:32:57.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/2, changed state to up
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#int e0/1
R2(config-if)#no sh
R2(config-if)#
*Apr 4 10:33:14.475: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
R2(config-if)#
*Apr 4 10:33:15.475: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
R2(config-if)#ip add
R2(config-if)#ip address 10.10.11.1 255.255.255.0
R2(config-if)#

 

R3 Initial Configure

R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#int e0/0
R3(config-if)#no sh
R3(config-if)#ip add
R3(config-if)#ip address
*Apr 4 10:34:36.471: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
R3(config-if)#ip address 1
*Apr 4 10:34:37.483: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
R3(config-if)#ip address 10.10.11.2 255.255.255.0
R3(config-if)#int e0/1
R3(config-if)#no sh
R3(config-if)#ip add
R3(config-if)#ip address
*Apr 4 10:34:58.187: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Apr 4 10:34:59.203: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#

 

Now We Configure OSPF

Configure OSPF in Area 1 on R1 Router interface e0/0

Configure OSPF in Area 0 on R1 Router interface e0/1,R2 Router interface e0/0,e0/2

Configure OSPF in Area 2 on R2 Router interface e0/1,R3 Router interface e0/0,e0/1

R1(config)#int e0/0

R1(config-if)#ip ospf 10 area 1

R1(config)#int e0/1

R1(config-if)#ip ospf 10 area 0

R1(config-if)#
*Apr  4 10:45:34.323: %OSPF-5-ADJCHG: Process 10, Nbr 192.168.2.1 on Ethernet0/1 from LOADING to FULL, Loading Done

R2(config)#interface range e0/0,e0/2
R2(config-if-range)#ip os
R2(config-if-range)#ip ospf 10 are
R2(config-if-range)#ip ospf 10 area 0
R2(config-if-range)#
*Apr 4 10:45:34.279: %OSPF-5-ADJCHG: Process 10, Nbr 192.168.1.1 on Ethernet0/0 from LOADING to FULL, Loading Done

R2(config-if-range)#interface e0/1
R2(config-if)#ipos
R2(config-if)#ip os
R2(config-if)#ip ospf 10 ar
R2(config-if)#ip ospf 10 area 2

R2(config-if)#
*Apr  4 10:47:56.803: %OSPF-5-ADJCHG: Process 10, Nbr 192.168.3.1 on Ethernet0/1 from LOADING to FULL, Loading Done

 

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#int
R3(config)#interface ra
R3(config)#interface range e0/0,e0/1
R3(config-if-range)#ip os
R3(config-if-range)#ip ospf 10 ar
R3(config-if-range)#ip ospf 10 area 2
R3(config-if-range)#
*Apr  4 10:47:56.915: %OSPF-5-ADJCHG: Process 10, Nbr 192.168.2.1 on Ethernet0/0 from LOADING to FULL, Loading Done

 

Verification

R1# show ip route
The output displays ‘O’, ‘O IA’ routes.
The ABR can be verified by using the following command
R1# show ip ospf border-routers
R2#show ip route
R2#show ip ospf border-routers
R3#show ip route
Check Connectivity From PC1
PC1> ip 192.168.1.2/24 192.168.1.1
Checking for duplicate address…
PC1 : 192.168.1.2 255.255.255.0 gateway 192.168.1.1PC1> ping 192.168.2.1
84 bytes from 192.168.2.1 icmp_seq=1 ttl=254 time=15.351 ms
84 bytes from 192.168.2.1 icmp_seq=2 ttl=254 time=2.345 ms
84 bytes from 192.168.2.1 icmp_seq=3 ttl=254 time=3.490 ms
84 bytes from 192.168.2.1 icmp_seq=4 ttl=254 time=3.697 ms
84 bytes from 192.168.2.1 icmp_seq=5 ttl=254 time=6.066 ms

PC1> ping 192.168.2.2
84 bytes from 192.168.2.2 icmp_seq=1 ttl=62 time=5.687 ms
84 bytes from 192.168.2.2 icmp_seq=2 ttl=62 time=5.380 ms
84 bytes from 192.168.2.2 icmp_seq=3 ttl=62 time=3.344 ms
84 bytes from 192.168.2.2 icmp_seq=4 ttl=62 time=8.198 ms
84 bytes from 192.168.2.2 icmp_seq=5 ttl=62 time=11.620 ms

PC1> ping 192.168.3.2
84 bytes from 192.168.3.2 icmp_seq=1 ttl=61 time=5.950 ms
84 bytes from 192.168.3.2 icmp_seq=2 ttl=61 time=3.718 ms
84 bytes from 192.168.3.2 icmp_seq=3 ttl=61 time=12.492 ms
84 bytes from 192.168.3.2 icmp_seq=4 ttl=61 time=9.263 ms

 

 

 

 

 

 

Related posts

Leave a Comment