How to Configure PPPOE Server on Mikrotik

PPPOE Server on Mikrotik

Point to Point Protocol over Ethernet (PPPOE). PPPoE protocol was published by the IETF in 1999. PPPOE use standard method encryption, authentication, and compression specified by PPP.

in this tutorial we share how to configure PPPOE Server on Mikrotik

Task 1

IP Pool Configure

Task 2

PPPOE Server Configure

Task 3

PPPOE Profile Configure

Task  4

PPPOE User Create

Task 4

IP blocks for different bandwidth packages

 

Task 1 Configure

[admin@XYZ] /ip pool> add name=512KB ranges=192.168.1.2-192.168.1.254

[admin@XYZ] /ip pool> add name=1M ranges=192.168.2.2-192.168.2.254

[admin@XYZ] /ip pool> add name=2M ranges=192.168.3.2-192.168.3.254

 

Task 2 Configure

/interface pppoe-server server

Add service-name=”PPPOE-SERVER” interface=LAN max-mtu=1480 max-mru=1480

mrru=disabled authentication=pap,chap keepalive-timeout=10 one-session-per-host=yes

max-sessions=0 default-profile=default

Task 3 Configure

/ppp profile

set name=”default” use-mpls=default use-compression=default
use-encryption=default only-one=yes change-tcp-mss=yes address-list=””
dns-server=8.8.8.8,4.2.2.2

Task 4 Configure

/ppp secret
add name=Test service=pppoe password=123 profile=PPPOE local-address=192.168.2.1 remote-address=1M

add name=Test1 service=pppoe password=123 profile=PPPOE local-address=192.168.3.1 remote-address=2M

 

Task 4 Configure

Bandwidth Control Using PCQ Method:
/Queue type
add name=PPPOE_1M_DOWNLOAD kind=pcq pcq-rate=1M pcq-classifier=src-address
add name=PPPOE_1M_UPLOAD kind=pcq pcq-rate=1M pcq-classifier=dst-address

add name=PPPOE_2M_DOWNLOAD kind=pcq pcq-rate=1M pcq-classifier=src-address
add name=PPPOE_2M_UPLOAD kind=pcq pcq-rate=1M pcq-classifier=dst-address

/queue simple

add  name=”PPPOE-1M User” target-addresses=192.168.2.0/24
queue type=PPPOE_1M_UPLAOAD/PPPOE_1M_DOWNLOAD

add  name=”PPPOE-2M User” target-addresses=192.168.3.0/24
queue type=PPPOE_2M_UPLAOAD/PPPOE_2M_DOWNLOAD

 

 

Posted By: Techguru

 

 

 

 

 

Related posts

Leave a Comment